[tpop3d-discuss]Compiling with mysql support

James Gurney james at globalmegacorp.org
Mon, 10 May 2004 15:38:19 -0700

Banging my head against a wall here trying to get mysql support compiled 
in. My configure line is as follows:

./configure --enable-auth-passwd --disable-auth-pam 
--enable-shadow-passwords --enable-mbox-bsd --enable-tls 
--enable-fcntl-locking --dis
able-dotfile-locking --enable-auth-mysql 

This results in the error:

configure: error: vmail-sql authentication enabled, but mysql_init 
doesn't seem to be available.

Searching the mail archives seemed to indicate that I should modify the 
configure script to include -lz, although it appears to be there 
already. However, it doesn't seem to be actually using -lz when it 
compiles the test. From config.log:

configure:7027: checking for mysql_init
configure:7077: gcc -o conftest -g -O2 
-I/usr/local/mysql-3.23.49a-pc-linux-gnu-i686/include -I/usr/include 
-L/usr/local/mysql-3.23.49a-pc-linux-gnu-i686/lib/ -L/usr/lib confte
st.c -lssl -lmysqlclient -lcrypt  >&5
In function `my_uncompress':
my_compress.o(.text+0xa2): undefined reference to `uncompress'
In function `my_compress_alloc':
my_compress.o(.text+0x13a): undefined reference to `compress'
collect2: ld returned 1 exit status

I've tried re-extracting the archive and starting from scratch, so 
there's nothing cached, but still no go. I've considered the possibility 
that maybe my mysql version is a little old. Upgrading it is the next 
thing on my todo list, but I thought I'd throw it out here first to see 
if anyone has any other suggestions.