[tpop3d-discuss] auth_mysql trouble

Dmitry Nemtchinov dima at nival.com
Wed, 19 Dec 2001 14:17:51 +0300

	Seems I have the same trouble as it was described by Mark Moseley here:

	Here is my tpop3d.conf:

listen-address: xxx.xxx.xxx.xxx
max-children: 20

mailbox: maildir:/var/mail/$(user)

#auth-pam-enable: yes
auth-passwd-enable: yes
auth-passwd-mail-group: mail
auth-mysql-enable: yes
auth-mysql-mail-group: mail
auth-mysql-hostname: localhost
auth-mysql-database: mail_users
auth-mysql-username: mailkeep
auth-mysql-password: xxxxxx
auth-mysql-pass-query: SELECT
FROM user WHERE user.User='$(local_part)'

	tpop3d -h output is:

Available authentication drivers:

  auth-pam         Uses Pluggable Authentication Modules
  auth-passwd      Uses /etc/passwd or /etc/shadow
  auth-mysql       Uses a MySQL database
  auth-other       Uses an external program

Available mailbox drivers:

  bsd              BSD (`Unix') mailspool
  maildir          Qmail-style maildir
  empty            Empty mailbox

This tpop3d does not have TCP Wrappers support.

	maillog about described events:

Dec 19 12:29:45 comm tpop3d[9678]: listening on address xxx.xxx.xxx.xxx,
port 110, domain nival.macomnet.net
# server was started
Dec 19 12:29:45 comm tpop3d[9678]: 2 authentication drivers successfully
# both auth-mysql and auth-passwd schemes loaded
Dec 19 12:29:45 comm tpop3d[9678]: net_loop: tpop3d version 1.3.5
successfully started
Dec 19 12:29:49 comm tpop3d[9678]: listeners_post_select: client
[6] connected
# client connected
Dec 19 12:30:07 comm tpop3d[9678]: connection_do: client
`[6]': 1 authentication failures
# authenticated
Dec 19 12:30:09 comm tpop3d[9678]: connections_post_select: client
[6] disconnected
# disconnected
Dec 19 12:30:21 comm tpop3d[9678]: net_loop: terminating on signal 15
# tpop3d finished

	MySQL log about same events:

011219 12:29:45      20 Connect     mailkeep@localhost on mail_users
# tpop3d started, connected to mysql
011219 12:30:21      20 Quit
# tpop3d finished, disconnected

	As you can see above no queries nether valid no invalid was not send from
tpop3d to mysql. As I see mysql authentication was not involved at all. I
tried to disable auth-passwd. Nothing had been changed, but only one
authentication driver had been loaded. Also I tried to change use query
without quotation marks in $(local_past). Nothing has been changed at all.

	Could you please help me or describe what was wrong. Hope for your help.

	Dmitry Nemtchinov