[tpop3d-discuss] auth_mysql trouble

Chris Lightfoot chris at ex-parrot.com
Wed, 19 Dec 2001 11:28:51 +0000

On Wed, Dec 19, 2001 at 02:17:51PM +0300, Dmitry Nemtchinov wrote:
> 	Seems I have the same trouble as it was described by Mark Moseley here:
> 	http://lists.beasts.org/pipermail/tpop3d-discuss/2001-November/000344.html
> As you can see above no queries nether valid no invalid was not send from
> tpop3d to mysql. As I see mysql authentication was not involved at all. I
> tried to disable auth-passwd. Nothing had been changed, but only one
> authentication driver had been loaded. Also I tried to change use query
> without quotation marks in $(local_past). Nothing has been changed at all.

What username and password are you using? I notice from
your config that append-domain is not switched on, so
auth-mysql will only be used if the `username' is of the
form local_part[@%!]domain. If there is no domain-part,
then auth-mysql won't be called at all.

 If you see a long line of rats streaming off of a ship, the correct
 assumption is not `Gosh, I bet that's a real nice boat now that those
 rats are gone.' (Mike Sphar)