[Vmail-discuss] cannot find router driver "aliasfile"

Bob Wyman abacus@xxxxxxxxxxxxxx
Tue, 02 Apr 2002 11:39:07 -0500

I have run into a strange problem, I had finished setting up vmail,
everything was working nicely, the web interface worked, I could send mail
was getting ready to test if I could receive it when I restarted exim and
now it will not start anymore and outputs the following error:

2002-04-02 08:06:00 Exim configuration error in line 412:
  router virtual_forward: cannot find router driver "aliasfile"

Line 412 is the fist instance that calls the router driver "aliasfile" The
strange part is that it was running perfectly with this same configure file,
and nothing was changed in the configure file before exim was restarted. I
have tried a recompile (assuming something was corrupted) and re-installed
exim, same error. I can only guess why the router driver "aliasfile" is
suddenly broken, and I am stumped as how to get it fixed.

I am running my vmail-sql-0.6 setup on IRIX 6.5 with Exim-4.02,
tpop3d-1.3.5, mysql-3.23.49

Everything was compiled with the SGI MipsPro compiler with the exception of
tpop3d which was compiled with gcc due to issues it had with the sgi cc

Any help would be greatly appreciated I am frustrated because everything
appeared to be running smoothly and now I am back to square one!