[tpop3d-discuss] MySQL troubles

Richard Stockton richard at richardleestockton.org
Mon, 03 Mar 2003 18:46:49 -0800

Hi Ivo,

At 09:47 AM 3/1/03 +0100, I.M. Conradi wrote:
>Why don't you install tpop3d from the ports?

I'm afraid the ports don't allow me to do the customization
I need to do to the source code to limit what is logged, so
that I have a usable "pop.log" for my purposes.

However, I DID find a solution, crass as it is.  Since I was
certain (after viewing the Makefiles and configure) that the
"mysql.h" file was where it needed to be, I simply commented
out the checking code that was generating the error in the
"configure" file.  I figured at worst it just would not work.
But it now works just fine, and I have tpop3d happily writing
authenticated IPs to my MySQL database (and PostFix reading
them, but that's another matter).  Do I recommend that solution?
No, certainly not, but it worked for me.

So....... Never mind!

But I do appreciate you trying to help, thanks very much.
  - Richard

>-----Original Message-----
>From: tpop3d-discuss-admin@lists.beasts.org
>[mailto:tpop3d-discuss-admin@lists.beasts.org] On Behalf Of Richard
>Sent: Friday, February 28, 2003 10:55 PM
>To: tpop3d-discuss@lists.beasts.org
>Subject: [tpop3d-discuss] MySQL troubles
>I am trying to enable mysql with tpop3d.  I actually only want to use
>the "auth-mysql-onlogin-query:" directive for use with my
>pop-before-smtp, but it appears that I have to enable auth-mysql to make
>that happen, is that right?
>However, when I try to configure with;
>./configure --enable-mbox-maildir --enable-auth-mysql
>   --with-mysql-root=/usr/local --enable-auth-passwd
>I get this error;
>configure: error: vmail-sql authentication enabled, but can't find
>MySQL is installed (and running), and "mysql.h" exists in
>"/usr/local/include/mysql/mysql.h", AND there is a link to that file at
>"/usr/local/include/mysql.h".  I also tried putting it in
>"/usr/include/mysql.h", to no avail.
>Versions: FreeBSD 5.0, MySQL 3.23.55, tpop3d 1.4.2,
>Postfix 2.0.3
>If I leave out "--enable-auth-mysql" (but leave in the
>"--with-mysql-root=/usr/local"), I don't appear to get the mysql stuff
>compiled in, although tpop3d then runs okay.

  - Richard
  | Richard Lee Stockton
  | Senior Systems Manager: http://adhost.com/   Adhost: 425-454-9520 |
  | http://richardleestockton.org/